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Product Overview

¢ “Product Description” on page 1-2
¢ “Reduce Computations by Using RF Simulation Techniques” on page 1-3
¢ “Working with SImRF Software” on page 1-12
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Product Description

Design and simulate RF systems

SimRF™ provides a component library and simulation engine for designing
RF systems. It includes mixers, amplifiers, S-parameter blocks, and other
basic blocks for architectural design and modeling of wireless transceivers.
You can connect these components arbitrarily to form diverse architectures
and to model system-level impairments. SimRF enables simulation of

RF gain, noise, and intermodulation distortion commonly attributed to

RF amplifiers. It provides circuit envelope technology for simulating RF
impairments uniquely associated with mixers, including image rejection,
reciprocal mixing, local oscillator phase offsets, DC conversion, and DC
offsets. Equivalent baseband technology is also included, enabling fast
simulation of single-carrier cascaded systems.

Key Features

e Multiple carrier-frequency models
¢ General N-port models and S-parameter data files

® Passive components, including resistors, capacitors, inductors, and general
impedance blocks

¢ Weakly nonlinear 3-port mixers and 2-port amplifiers specified by noise
figure, IP2, IP3, and data files

® Intra-model signal probing
¢ (Circuit envelop technology for high-fidelity simulation

e Equivalent baseband technology for fast simulation
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Reduce Computations by Using RF Simulation Techniques

In this section...

“Simulate a Passband Signal in Simulink Software” on page 1-4

“Compare Passband and Baseband Signals in SiImRF Software” on page 1-5

“Simulate the Envelope of a Baseband Signal” on page 1-9

This example shows how to use circuit-envelope simulation to reduce the
number of time steps required to simulate a simple signal by a factor of 100.

Traditional methods of circuit simulation are not ideal for RF systems.
High-frequency carriers require very small time steps. This approach results
in a long simulation time. Circuit-envelope simulation is a solution for
modeling RF signals accurately, while also reducing simulation time.
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The preceding figure illustrates a signal x(¢) for which circuit-envelope
simulation is ideal. The signal consists of a time-varying modulation on

a high-frequency carrier. In many RF applications, the frequency of the
modulation A(¢) is orders of magnitude less than the frequency of the carrier,

fe-

SimRF software handles the carrier cos(2mf,t) analytically, so it only needs
to simulate the modulation. The redefined system that the software uses is
mathematically equivalent to the original. However, by taking time steps
on the scale of the modulation instead of the carrier, the software produces
equivalent results in less time.
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Simulate a Passband Signal in Simulink Software
The model

ex_simrf_tut_passband

simulates a 1-GHz sine wave using fundamental Simulink® blocks. This
section of the example shows you how to model the modulation of a real
passband signal with in-phase and quadrature components.

1>] ex_simtf_tut_passband EI@

File Edit ‘“iew Simulation Format Tools  Help

O =E & » |58-E| |N0rmal j
1 GHz cosine |_’
3 e i
In-phase modulation |:|
4 - w Real Paszband Scope
Quadrature modulation
™
W
1 GHz zsine
Ready 100% FizedStepDiscrete

The system specifies a real passband signal x(f) according to the formula

x(t) = I(t)cos (2 f,t) - Q(t)sin (27 f,t )

where:

e ](¢) is the in-phase part of the modulation, equal to 3 in this example,
modeled by the Constant block labeled In-phase modulation.

® Q(t) is the quadrature part of the modulation, equal to 4 in this example,
modeled by the Constant block labeled Quadrature modulation.
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® f.is the carrier frequency, equal to 1 GHz in this example.

Running the model produces the following output on the scope.

u Real Passband Scope E'@ ﬁ
SEPLY aEB 2ASRE -

P

The output signal at the Real Passband Scope has a magnitude of 5 and a
phase shift consistent with the specified in-phase and quadrature amplitudes.

In the Configuration Parameters dialog box, the Fixed-step size
(fundamental sample time) parameter has been set to 1/20*1e-9. This
value is on the order of the wavelength of the carrier. The simulation takes a
total of 101 samples—20 per cycle.

Compare Passband and Baseband Signals in SimRF
Software
The model

ex_simrf_tut_compare
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simulates a 1-GHz sine wave using SimRF blocks. This example builds on
the results of the previous section, “Simulate a Passband Signal in Simulink
Software” on page 1-4.

1>] ex_simrf_tut_compare EI@

File Edit View Simulation Format Tools Help

O EE& (T |5&-5' |Nu:urrna| j
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g
344 L RF RF

Q

Y

Complex medulaticn

SimRF SimRF Cutporti I/ Scope
Inport

RF 5L =|:|

Real Passband Scope

fxp=0

SimRF Outport

Solver

Configuration RE SimRF
FParameters

Ready 100% FixedStepDiscrete

The system simulates a real passband signal as the real part of a complex
passband signal according to the formula

x(t) = Re[ (I(t) + jQ®))exp(j - 27 f.t) | = I(¥) cos (27 f.t) - Q®)sin (27 f,)

where:

® J(t) + jQ(¢) is the complex-valued modulation, equal to 3 + 4j.

® f is the angular frequency, equal to 1 GHz.

Contrary to the Simulink passband implementation in the previous section,
the complex baseband signal driving the SimRF system does not include the

carrier. Instead, the SimRF environment handles the carrier analytically.
The carrier appears in four different blocks in the SimRF environment:
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¢ In the SimRF Inport block, the Carrier frequencies parameter defines
the carrier frequencies of the modulations entering from outside the SimRF
environment. In this example, there is only one input signal, and only one
carrier (1 GHz, specified as 1e9 Hz).

® In the SimRF Outport block, the Carrier frequencies parameter specifies
the signal on the 1e9 Hz carrier (1 GHz) as Simulink signals. These
signals appear at the I and Q ports. The Output parameter is set to Real
Passband, so this signal represents a real passband signal on the 1-GHz
carrier.

¢ In the block labeled SimRF Outportl block, also a StmRF Outport block,
the Carrier frequencies parameter specifies the signal outputted on the
1e9 Hz carrier (1 GHz) as Simulink signals. These signals appear at the I
and Q ports. The Output parameter is set to In-phase and Quadrature
Baseband, so these signals represent the in-phase and quadrature
modulations of the signal on the 1-GHz carrier.

¢ In the SimRF Parameters block, the Carrier frequencies parameter
specifies all of the carriers to be modeled in the SimRF circuit-envelope
simulation environment. In this example, only one carrier is specified.

Note The Solver Configuration block, required in SimRF models, retains its
default settings.

Running the model produces the following output on the scopes.
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P

n Real Passband Scope E'@ ﬁ
SEPLPLrr aAERB AR -~

The Real Passband Scope displays the same output as the example in the
previous section, “Simulate a Passband Signal in Simulink Software” on page
1-4. The signal has a magnitude of 5 and a phase shift consistent with the
specified in-phase and quadrature amplitudes.
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’nli'Qﬂcupe EI@
SEPLPLrr aAERB AR -~

|n-phase modulation

Huadrature modulation

The 1-GHz carrier itself does not appear in the output. The results correspond
to the real and imaginary parts of the Complex modulation at the input of the
system. They also correspond to the In-phase modulation and Quadrature
modulation blocks in “Simulate a Passband Signal in Simulink Software”

on page 1-4.

In the Configuration Parameters dialog box, the Fixed-step size
(fundamental sample time) parameter has been set to 1/20*1e-9. This
value is on the order of the wavelength of the carrier. The simulation takes a
total of 101 samples—20 per cycle.

Simulate the Envelope of a Baseband Signal

The model

ex_simrf_tut_envelope

simulates the envelope of a 1-GHz sine wave using SImRF blocks. This
example builds on the results of the previous section, “Compare Passband and
Baseband Signals in SimRF Software” on page 1-5.
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1>] ex_simrf_tut_envelope EI@

File Edit View Simulation Format Tools Help

O =E & » |5&-5' |Nu:urrna| j
! L]
3+di - SL RF RF
Q >
Complex medulaticn pe SimAF O as
imRF im utport /Q Scope
Inport
=0
Solver
Configuration .
SimRF
RF FParameters
Ready 100% FixedStepDiscrete

The system is almost identical to the system in the previous section, except:

¢ The model contains only one SimRF Outport block and only one scope. The
SimRF environment outputs in-phase and quadrature modulations of the
1-GHz signal. However, this system does not output a real passband signal.

¢ In the Configuration Parameters dialog box, the Fixed-step size

(fundamental sample time) parameter is greater. Its value is 5e-9
instead of 1/20*1e-9.

Running the model produces the following output at the scope.
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’nli'Qﬂcupe EI@
SEPLPLrr aAERB AR -~

iodulation

The I/Q Scope displays the in-phase and quadrature modulations of the
1-GHz signal. The 1-GHz carrier itself does not appear in the output. The
results correspond to the real and imaginary parts of the Complex modulation
at the input of the system.

In contrast to the models in the previous two sections, Simulink works
differently in this model. Here, Simulink does not have to simulate this
system using a fundamental sample time on the order of the wavelength
of the carrier. Because the modulations are constant in this example, only
two sample points are needed.

The model uses a value of 5e-9 for the Fixed-step size (fundamental
sample time) parameter. This value equals the Stop time because the
modulations are constant. Compared to the preceding examples, which use a
sample time of 1/20*1e-9, this model simulates accurately with a time step
100 times larger. This step size results in a reduction of total sample time by
a factor of 100, excluding the initial time step at time O.

1-11
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Working with SimRF Software

1-12

In this section...

“Understanding the SimRF Environment” on page 1-12
“Required and Related Products” on page 1-13

“Using the SiImRF Documentation” on page 1-13

Understanding the SimRF Environment

Groups of interconnected SimRF blocks and the algorithms that model the RF
system that they represent comprise the SimRF environment. In the SimRF
environment, all blocks fall into one of the three following categories.

Blocks that Operate Within the SimRF Environment

These blocks contribute to the physical representation of an RF system.
Most SimRF blocks fall into this category, including all blocks in the SimRF
Elements and Sources libraries. For example, a Resistor block can model a
source impedance or part of a matching network, and an Amplifier block
could model a physical RF amplifier. Both of these blocks model physical
components.

Blocks within the SimRF environment connect via bidirectional SimRF
signals. SimRF signals are an implementation of Simscape physical signals
whose defined Through and Across variables represent current and voltage,
respectively. For an introduction to Simscape™ software and physical signals,
see Basic Principles of Modeling Physical Networks.

Blocks that Convert Between the SimRF and Simulink
Environments

These blocks provide an interface from an RF system to a larger design.
SimRF Inport and SimRF Outport blocks fall into this category. For example,
you can construct a signal using blocks from Communications System
Toolbox™ or DSP System Toolbox™ libraries, and input that signal into the
SimRF environment using a SimRF Inport block.



Working with SimRF™ Software

The SimRF Parameters and Solver Configuration blocks

These blocks manipulate the environment itself. They are not strictly part of
the physical system. However, they connect directly with other SimRF blocks
using physical connections. To use these blocks, connect them to any part of
the RF system. Because they are not part of the physical representation of the
system, they have the same effect regardless of where they connect within
the environment.

To run models containing SimRF blocks, you must connect a Solver
Configuration block to the SimRF environment. Additionally, to simulate
carriers besides 0 Hz, or to model noise in the SimRF environment, you must
connect a SimRF Parameters block to the SimRF environment.

Required and Related Products

Several MathWorks® products are relevant to the tasks that you can perform
with the SimRF software and extend the capabilities of MATLAB®,

To install SimRF software, you must have the following products:

¢ RF Toolbox™ — MATLAB functions for modeling RF systems.
® Simscape — Software tools for modeling and simulating multidomain

physical systems.

SimRF software benefits from, but does not require, installation of the
following recommended products:

¢ Communications System Toolbox — Simulink blocks and MATLAB
functions for time-domain simulation of modulation and demodulation of
a wireless communications signal.

e DSP System Toolbox — Simulink blocks and MATLAB functions for
time-domain simulation of filtering of a modulated communications signal.

Using the SimRF Documentation

¢ “Expected Background” on page 1-14
¢ “What Chapters Should I Read?” on page 1-14

1-13
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Expected Background

Topics in this guide assume that you are already familiar with:

¢ Using MATLAB to write and execute scripts and functions.

¢ Using Simulink to create and simulate block diagrams.

What Chapters Should | Read?

If you are using SimRF software for the first time, read the “Reduce
Computations by Using RF Simulation Techniques” on page 1-3 and Chapter
2, “Frequency Conversion” examples to learn how to build SimRF models
and to gain familiarity with the SimRF environment. Once you are familiar
with these concepts, select additional sections of the documentation to read
based on your needs:

¢ For information on applying SimRF software to RF receiver design, refer
to the SimRF User’s Guide.

® To learn more about the applications of SiImRF software and how SimRF
software interacts with other MathWorks products, see the Demos section.

® For a detailed explanation of each SimRF block, see the Blocks —
Alphabetical List .

¢ For information on simulation using the Simscape platform, see Basic
Principles of Modeling Physical Networks.

1-14



Frequency Conversion

o “Specify the Circuit Envelope Simulation Environment” on page 2-2
e “Model an RF Mixer” on page 2-6
e “Filter Mixing Products” on page 2-15
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Specify the Circuit Envelope Simulation Environment

In this section...

“Access Circuit Envelope Libraries” on page 2-2
“Ground the RF System” on page 2-3

“Configure the SimRF Environment” on page 2-4

“Simulate the SimRF Environment” on page 2-5

This section of the tutorial shows you how to:
e Use a Solver Configuration block to provide local solver settings to the
SimRF environment

¢ Use a SimRF Parameters block to define the carriers and global noise
behavior in the SimRF environment.

e Use a Ground block to reference a model to electrical ground.

The Solver Configuration and Ground block are the bare minimum that
SimRF software requires in order to perform circuit-envelope simulation.
Models that are missing one of these two blocks do not run. In order to

simulate the SimRF environment at carrier frequencies other than 0 Hz, a
model must also contain a SimRF Parameters block.

To begin, open a new model by selecting File > New > Model.

Access Circuit Envelope Libraries

Open the SimRF library by clicking the Start button and selecting
Simulink > SimRF > Block Library (Circuit Envelope), or type

simrflib

at the MATLAB Command Window prompt.
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ﬂ Library: simrflibvl EI@

File Edit View Format Help

Gircuit Envelope ‘

Equivalent Baseband

Idealized Baseband

SimRF Library 3.2
Copyright 2003-2011 The MsthWorks, Inc.

Ready 100% Locked

The SimRF library contains three sublibraries:

® The Circuit Envelope library contains blocks for circuit-envelope
simulation. This manual often refers to the Circuit Envelope library as the
SimRF library. The SimRF Getting Started Guide and SimRF User’s Guide
pertain exclusively to this library.

¢ The Equivalent Baseband and Idealized Baseband library contain blocks for
equivalent-baseband simulation. Refer to the Equivalent Baseband section
of the SimRF documentation for more information on using these blocks.

To continue, double-click the Circuit Envelope library.

Ground the RF System

Place a Ground block in your model:

1 In the SimRF library, double-click Elements to open the SimRF Elements
library.

2 Drag and drop a Ground block onto your model. In the library, the block
is abbreviated 'Gnd’.

Connecting SimRF models to ground provides an electrical reference for the
system, from which node voltages are defined. A SimRF model is grounded if:

¢ The model contains a Ground block that connects to the SimRF
Environment, or

® The model contains an Amplifier, Continuous Wave, Mixer, Noise,
Sinusoid, or S-Parameters block that is internally grounded. To internally
ground one of these blocks, select the Ground and hide negative
terminals check box in the block dialog box.
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Configure the SimRF Environment
To continue the tutorial:

1 Place a Solver Configuration block in your model. In the SimRF library,
double-click Utilities to open the SimRF Utilities library, then drag and
drop a Solver Configuration block onto your model.

2 Place a SimRF Parameters block in your model. If the SimRF Utilities
library is not already open, double-click Utilities to open it, then drag and
drop a SimRF Parameters block onto your model.

3 Connect the Ground, Solver Configuration, and SimRF Parameters blocks
to each other. The following figure shows one possible configuration.

B esimi_tut_env (BN BB (=S
File Edit View Simulation Format Teels Help
b eSS » 0 Normal A

Ready 100% VariableStepDiscrete

A model can contain multiple Solver Configuration and SimRF Parameters if
all of the following conditions are met:

¢ Each Solver Configuration and SimRF Parameters block connects to a
separate SimRF environment.

® No two Solver Configuration or SimRF Parameters blocks connect to the
same environment.

¢ The separate SimRF environments are isolated from each other in separate
subsystems.

2-4
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Warning Simulating more than one SimRF environment without
using subsystems is not supported.

Simulate the SIimRF Environment

To run the model, select Simulation > Start.

The model simulates according to the default settings of the Solver
Configuration and SimRF Parameters blocks and produces no output:

¢ In the SImRF Parameters block dialog, the Carrier frequencies
parameter specifies a carrier of 0 Hz in the system. In the next section,
“Model an RF Mixer” on page 2-6, you specify additional carriers for
circuit-envelope simulation.

¢ In the Solver Configuration block dialog, the Use local solver check box is
cleared, so the model uses the specified global solver. The examples in the
SimRF User’s Guide show you how to configure the SimRF environment
to use a local solver.
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Model an RF Mixer

In this section...

“Build the RF System” on page 2-7

“Probe Circuit Envelopes Waveforms” on page 2-7

“Define Model Variables” on page 2-8

“Specify Block Parameters for RF Simulation” on page 2-11

“Simulate Frequency Conversion in an RF Mixer” on page 2-13

This section of the tutorial shows you how to:

e Use a Sinusoid block to model the envelope of an amplitude-modulated
(AM) waveform.

® Use a Continuous Wave block to model the constant envelope of an ideal
local oscillator (LO).

e Use a Mixer block to downconvert the AM waveform to an intermediate
frequency (IF).

i fir

fig fro ey

The preceding figure illustrates frequency conversion. A signal modulated on
the carrier f,, mixes with a local oscillator at f; . The operation downconverts
fri to fip = frr— f1o0- The upper mixing product f,z + f; is not modeled.

To begin, open the model you created in the previous section, “Specify the
Circuit Envelope Simulation Environment” on page 2-2, or type

ex_simrf_tut_env

2-6
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at the MATLAB Command Window prompt.

Build the RF System

Add blocks to the SimRF environment that create a working model for
frequency conversion:

® From the SimRF Sources library, drag and drop a Continuous Wave block
and a Sinusoid block onto your model.

®* From the SimRF Elements library, drag and drop a Mixer block and a
Resistor block onto your model.

Connect the blocks as shown in the following figure.

W exsimif_tut_mixer © E@
File Edit View Simulation Format Tools Help
bed& e} »ou fies  [Nomal

Ready 100% ode23t

This configuration specifies an AM waveform at the input port of the mixer,
an LO at the LO port of the mixer, and a 50-Q termination at the output
of the mixer.

For more information on organizing blocks on the Simulink canvas, see
“Changing a Block’s Appearance” in the Simulink User’s Guide.

Probe Circuit Envelopes Waveforms
At the output of the mixer:
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¢ From the SimRF Utilities library, drag and drop a SimRF Outport block
onto your model.

®* From the Simulink Commonly Used Blocks library, drag and drop a Scope
block and a Terminator block onto your model.

Connect the blocks as shown in the following figure.

W exsimif_tut_mixer E@
File Edit View Simulation Format Tools Help
Died& » [le-5  [Momal

Terminator
Mixer SimAF
R Outport

3
]
2 s &
5 o 7
’ &
o
K
o
ﬁ i
o

SimRF
s e

Ready 100% ode23t

This configuration uses a SimRF Outport block as a voltage sensor at the
output port of the mixer. The Simulink signal at the outport is the envelope of
the carrier or carriers specified in the block. A scope attached to the outport
plots the envelope. The Output parameter controls how signals are presented
at the output ports. To change the appearance of the block, follow one of

the workflows in the “Specify Block Parameters for RF Simulation” on page
2-11 section of this tutorial.

Define Model Variables

For models with blocks that share parameter values, specifying parameters
values using variables saves time and effort. For example, a frequency that
1s specified in the Carrier frequencies parameter of a SimRF Inport block
must also be specified SimRF Parameters block also appears in the Carrier
frequencies parameter of a block that uses that carrier. If you specify the
parameter with a variable for the model using one of the following procedures.

To define model variables, use one of the following workflows.
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Using an Initialization Function to Define Variables

Simulink models run MATLAB code stored in the initialization function
(InitFcn) each time the model starts. The MATLAB code runs in the base
workspace. If the initialization function stores variables in the MATLAB
workspace, the variables are overwritten every time the model executes the
initialization function.

Most models in the SimRF User’s Guide use the InitFcn to define model
variables.

1 Open the Model Properties dialog box by selecting File > Model
Properties.

2 In the Callbacks tab, within the Model callbacks pane, select the
InitFcn node.

3 In the Model initialization function pane, enter the following MATLAB

code:

modulationAmplitude = 1;
modulationFrequency 5e5;
LOAmplitude = 1;
LOFrequency = .95e9;
RFCarrier = 1e9;

For more information, see Using Callback Functions in the Simulink User’s

Guide.

Using the Model Explorer to Define Variables
From within the Model Explorer, add variables directly to the model

workspace. Model workspace variables do not interact with the base MATLAB

workspace.

1 Open the Model Explorer window by selecting View > Model Explorer,
or by right-clicking a block in your model and from the context menu,
selecting Explore.

2 On the Model Hierarchy pane, select the Model Workspace node for
your model.
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3 On the Contents pane, add the following variables to the workspace by
selecting Add > MATLAB Variable and editing the variable attributes.

Name Value
modulationAmplitude 1
modulationFrequency 500000
LOAmplitude 1
LOFrequency .95e+009
RFCarrier 1e+009
[ Model Explorer E=2(EsEE=T
File Edit View Tools Add Help
s R EHHELRNZ fFoe @R FTa2A
Search: by Name  Name: % Search
Mode! Hierarchy W B, | Contentsof: Model Workspace
“ El ;m:;‘a::x];ismﬂ Column View: |Data Objects * | Show Details 5 object(s]
o Bl excsimrt_tut_mixer Name Value Datalype Min Max Dimen
il Model Workspace M modulationfrequensy 500000
% vt | Boren 932008
ﬂ Simulink Des;gn\fe_rifie_rresu\ts & medulationAmplitude !
% Configuration (Active) H Loamplitude 1
M recarrier 1e+009
« . »
Contents Search Results

For more information, see The Model Explorer: Overview in the Simulink
User’s Guide.
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Using the Command Line to Define Variables

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;

hws = get_param(hmdl, '‘ModelWorkspace');
hws.assignin('modulationAmplitude’',1);
hws.assignin('modulationFrequency',5e5);
hws.assignin('LOFrequency',.95€9);
hws.assignin('LOAmplitude’',1);
hws.assignin('RFCarrier',1e9);

For more information on manipulating model workspace data, see Using
Model Workspaces in the Simulink User’s Guide.

Specify Block Parameters for RF Simulation
In this section, you:
¢ Configure the SImRF environment for multi-frequency circuit-envelope

simulation by specifying the Carrier frequencies parameter in the
SimRF Parameters block dialog box.

® Specify the attributes of the waveforms

¢ Configure global simulation settings.

To specify block parameters, use one of the following workflows.

Using Dialog Boxes to Set Parameters

1 Select Simulation > Configuration Parameters... to open the

Configuration Parameters dialog box. Specify the following parameters:

® Set Stop time to 1e-5.
® Set Solver to ode23t (mod. stiff/Trapezoidal).
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2 Double-click the Sinusoid block to open the Sinusoid Block Parameters
dialog box. Specify the following parameters:

® Set Sinusoidal amplitude in-phase to modulationAmplitude.
® Set Sinusoidal modulation frequency to modulationFrequency.

e Set Carrier frequencies to RFCarrier.

3 Double-click the Continuous Wave block to open the block dialog box.
Specify the following parameters:

¢ Set Constant in-phase value to LOAmplitude.

e Set Carrier frequencies to LOFrequency.

4 Double-click the SimRF Parameters block to open the block dialog box, and
set Carrier frequencies to [RFCarrier - LOFrequency, LOFrequency,
RFCarrier, RFCarrier + LOFrequency].

5 Double-click the SimRF Outport block to open the block dialog box. Specify
the following parameters:

e Set Output to In-phase and quadrature.

e Set Carrier frequencies to RFCarrier - LOFrequency.

Using the Command Line to Set Parameters

Execute the MATLAB code in this section at the command line to assign
variables directly into a model workspace.

In the Command Prompt window, type:

hmdl = bdroot;

set_param(hmdl, 'StopTime', '1e-5');

set_param(hmdl, 'Solver', 'o0de23t');

set_param([hmdl '/Sinusoid'],
'VA_I','modulationAmplitude’,
'Fmod', 'modulationFrequency’,
'"CarrierFreq', 'RFCarrier');

set_param([hmdl '/Continuous Wave'],
"IVoltage', 'LOAmplitude’,
'CarrierFreq', 'LOFrequency');



Model an RF Mixer

set_param([hmdl '/SimRF Outport'],
'CarrierFreq', 'RFCarrier - LOFrequency',
"OutputFormat', 'In-phase and quadrature');
set_param([hmdl '/SimRF Parameters'],
‘CarrierFreq',['[RFCarrier - LOFrequency,
'LOFrequency, '
'RFCarrier, '
'RFCarrier + LOFrequency]']l);

Simulate Frequency Conversion in an RF Mixer

Select Simulation > Start to run the model.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.

By default, SimRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink Preferences dialog box. To specify a cache folder:
1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

For more information about the Simulink interface, see Simulink Preferences
Window.

To view the results of the simulation, double-click the scope.

nScope E@
SB|[PLL AEBE B L u
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2 Frequency Conversion

The Sinusoid specifies a 1-V amplitude for the modulation on f, which the
mixer downconverts to f; The SImRF Outport block probes the intermediate
frequency and recovers the 1-V modulation amplitude. This value agrees with
a specified conversion gain of 0 dB in the mixer.
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Filter Mixing Products

Filter Mixing Products

In this section...
“Probe Multiple RF Carriers” on page 2-16
“Model an RF Filter” on page 2-17

“Simulate Filtering of RF Signals” on page 2-18

This section of the tutorial shows you how to:
e Configure a SimRF Outport block to probe multiple carrier frequencies
simultaneously.

e Model an analog filter in the SimRF environment using SimRF Capacitor
and Inductor blocks.

a

Low-pass filter 7=,
transmission

iiF Fro far fae + o

The preceding figure illustrates low-pass filtering of a low-side injection
system. Mixing f,, and f;, produces signals on the carriers f,, = fpr— f, and
frr + fLo- Adding a low-pass filter to the model reduces the power present

in the high-frequency signal.

To begin, open the model that you created in the “Model an RF Mixer” on
page 2-6 section, or type

ex_simrf_tut_mixer

at the Command Window prompt.
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Probe Multiple RF Carriers

The SimRF environment specifies the carriers fpn— f10, frp fro» a0d frp + L0
but the SimRF Outport block probes only the carrier fp, — f, . Examine

the carriers f,, — f,, and fpp + f,, by changing the model according to the
following workflow:

1 From the Simulink Commonly Used Blocks library, add a Demux block to
your model.

2 In the Scope block dialog box, click the Parameters button, then set
Number of Axes to 2.

3 In the SimRF Outport block dialog box, set Carrier frequencies to
[RFCarrier - LOFrequency, RFCarrier + LOFrequency]

4 Connect the blocks as shown in the following figure.

B ex_simif_tut_probe EI@
File Edit View Simulation Format Tools Help
== = b o fies  [Nomal

Ready 100% ode23t

5 Select Simulation > Start to run the model.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.



Filter Mixing Products

By default, SImRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink Preferences dialog box. To specify a cache folder:
1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

For more information about the Simulink interface, see Simulink Preferences
Window.

To view the results of the simulation, double-click the scope.

Bl scope [E=3 Bl =)
SB|[PLe ABB| B A% =

The first set of axes displays the modulation of specified carrier fz = frr— f10-
This carrier appears on the first set of axes because the Carrier frequencies
parameter of the outport specifies it first. The second set of axes displays the
modulation at fpr + f; . The modulation of the upper mixing product has the
same amplitude as the modulation of the downconverted signal.

Model an RF Filter

To begin, open the model that you created in the “Probe Multiple RF Carriers”
on page 2-16 section, or type

ex_simrf_tut_probe

at the MATLAB Command Window prompt.
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2 Frequency Conversion

1 From the Elements library, drag and drop one Capacitor and two Inductor
blocks onto your model

2 Set the Capacitance parameter of the capacitor to 40e-12 F.
3 Set the Inductance parameter of both inductors to 50e-9 H.

4 Connect the blocks as shown in the following figure.

Wi ex_simed_tut,Fitter (==
File Edit View Simulation Format Teols Help
D E-dS » 15 [Homal - B B8 w2

SimRF
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Ready 100% oded3t

This configuration models a third-order low-pass Butterworth filter with
a cutoff frequency of 1 rad/ns, or about 0.159 GHz. The high-frequency
mixing product is in the stopband of the filter. The low-frequency product
is in the passband.

Simulate Filtering of RF Signals

To begin, open the model that you created in the previous section, “Model
an RF Filter” on page 2-17, or type

ex_simrf_tut_filter

at the MATLAB Command Window prompt. Select Simulation > Start
to run the model.

To view the results of the simulation, double-click the scope.
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Filter Mixing Products

B scope [E=8 Ee =
SH LA AHREE BAF »

Time offset: 0

The filter attenuates the high-frequency signal at f,, + f;, and transmits the
signal at f, — f,, with minimal loss.

The SimRF documentation contains additional RF filter analysis and
simulation examples:

® The example Model an RF Filter Using S-Parameter Data uses an
S-Parameters block to model the filter shown in this tutorial.

¢ The demo AC Analysis of an RF System calculates the voltage transfer
function of an RF filter using harmonic balance analysis.
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